Joseph
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45627 Accepted: 17206
Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0
Sample Output
5
30
Source Code
Problem: 1012
Memory: 188K Time: 0MS
Language: C Result: Accepted
Source Code
#include<stdio.h>
int main()
{
int num[14]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
int k;
while(1)
{
scanf("%d",&k);
if(k==0)
break;
printf("%d\n",num[k]);
}
system("pause");
return 0;
}