HDU 1028(母函數),hdu1028函數
Online Judge
Online Exercise
Online Teaching
Online Contests
Exercise Author
F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Best Coder
betaVIP | STD Contests
Virtual Contests
DIY | Web-DIY
betaRecent Contests
jxust hsy
Mail 0(0) Control Panel
Sign Out
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19181 Accepted Submission(s): 13477
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
題意:給你一個正整數n,將該正整數拆分成若干整數的和,問你共有多少不同的拆分方法?
#include<bits/stdc++.h>
using namespace std;
int c1[205],c2[205];//c1用於記錄各項前面的系數,c2用於記錄中間值
int main()
{
int n;
while(~scanf("%d",&n))
{
//共有n個括號,先處理第一個括號,第一個括號裡每一項的系數都是1;
for(int i=0;i<=n;i++)
{
c1[i]=1;
c2[i]=0;
}
//因為共有n個括號,i表示正在處理第i個括號
for(int i=2;i<=n;i++)
{
//j表示正在處理第i個括號裡的第就項,
for(int j=0;j<=(n);j++)
{
for(int k=0;k+j<=n;k+=i)
{
c2[j+k]+=c1[j];
}
}
for(int j=0;j<=(n);j++)
{
c1[j]=c2[j];
c2[j]=0;
}
}
printf("%d\n",c1[n]);
}
return 0;
}