To The Max
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 30 Accepted Submission(s) : 16
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
[cpp]
/*
題目大意:給定一個含有正數和負數的矩陣,求其子矩陣的和的最大值
一維的情況很簡單,如何把一維的情況轉化為二維情況呢?
例如,對於本題的測試數據:
我們可以每次任選幾行,壓縮成一行,這樣就轉化為了一維情況。
例如,我們求1~2行中的最大子矩陣:即矩陣高為2(1~2行),寬為1:4的矩陣,可以先把1~2行相加,得到9 0 -13 2,再求這個單行的最大子段,由此就可以求得1~2行的最大子矩陣。
*/
#include<stdio.h>
#include<string.h>
int max,n;
int map[105][105],b[105];
int dp()
{
int i,sum=0,m=-1000;
for(i=0;i<n;i++)
{
sum=sum+b[i];
if(sum<0) sum=0;
if(sum>m) m=sum;
}
return m;
}
int main()
{
int i,j,k,t,ans;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&map[i][j]);
max=0;//一開始沒有初始化 沒法和後面的比較大小啊 所以WA了 所以要注意也謝細節問題
for(i=0;i<n;i++)//從第幾行開始
{
for(k=0;k<n;k++)//行數
{
if(i+k<n)
{
memset(b,0,sizeof(b));
for(t=i;t<=i+k;t++)
{
for(j=0;j<n;j++)
b[j]+=map[t][j];
}
ans=dp();
max=max>ans?max:ans;
}
}
}
printf("%d\n",max);
}
return 0;
}
作者:hnust_xiehonghao