Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!......
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009
Hint : 0! = 1, N! = N*(N-1)!
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4
5
Sample Output
24
120
求N! MOD 2009的結果
我們這可這樣想,如果在N!裡找幾個數乘的積等於2009就好了
結果我就弄了個循壞暴力了下,得知 2009=7*7*41=41*49;
也就是說當N>=49時N! MOD 2009=0;
當N<49時我們就可以暴力了,水了吧。
LANGUAGE:C
CODE:
#include<stdio.h>
int main()
{
int n;
__int64 mul;
while(scanf("%d",&n)!=EOF)
{
mul=1;
if(n>=49)
{
printf("0\n");
continue;
}
while(n>1)
{
mul*=n;
mul%=2009;
n--;
}
printf("%I64d\n",mul);
}
return 0;
}
作者:ultimater