Calculation 2
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1241 Accepted Submission(s): 518
Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
Output
For each test case, you should print the sum module 1000000007 in a line.
Sample Input
3
4
0
Sample Output
0
2
Author
GTmac
Source
2010 ACM-ICPC Multi-University Training Contest(7)——Host by HIT
題意:
輸入n 計算比n小的數中 和n不互質的數的和 %1000000007
[cpp]
/* if gcd(n,i)==1 then gcd(n,n-i)==1
所以 那麼對於n有phi(n)(歐拉函數)個小於n的數與n互質
由上面的公式可以知道 其中一個若為i則存在一個為n-i
那麼2者之和為n 這樣的一共有phi(n)/2對
故與n互質的所有數的和為 n*phi(n)/2
那麼與n不互質的 數就是(1+n-1)*(n-1)/2-n*phi(n)/2
*/
#include<stdio.h>
#include<math.h>
#define mod 1000000007
__int64 get_phi(__int64 x)// 就是公式
{
__int64 i, res=x;
for (i = 2; i <(__int64)sqrt(x * 1.0) + 1; i++)
if(x%i==0)
{
res = res / (__int64)i * (i - 1);
while (x % i == 0) x /= i; // 保證i一定是素數
}
if (x > 1) res = res / (__int64)x * (x - 1);//這裡小心別溢出了
return res;
}
int main()
{
__int64 n,ans;
while(scanf("%I64d",&n)!=EOF)
{
if(!n) break;
ans=((__int64)(1+n-1)*(n-1)/2-(__int64)n*get_phi(n)/2)%mod;//不能先除2再乘
printf("%I64d\n",ans%mod);
}
return 0;
}