Light Bulb
Time Limit: 1 Second Memory Limit: 32768 KB
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.
Input
The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.
Output
For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..
Sample Input
3
2 1 0.5
2 0.5 3
4 3 4
Sample Output
1.000
0.750
4.000
根據題意可以列出方程:設在地上的那段影子的長度為l1, l1/D=(h-L)/(H-L),得到l1=(h-L)*D/(H-L),所以影子的總長度為l1+L=(h-L)*D/(H-L)+L,只有一個未知數L,把L進行三分,在(0,h)這個范圍內。
[cpp]
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#define eps 1e-15
using namespace std;
double H,h,D;
double cal(double xx)
{
double ans=(h-xx)*D/(H-xx)+xx;
return ans;
}
double solve()
{
double left,right;
double mid,midmid;
double mid_area,midmid_area;
left=0;right=h;
while(left+eps<right)
{
mid=(left+right)/2;
midmid=(mid+right)/2;
mid_area=cal(mid);
midmid_area=cal(midmid);
if(mid_area<midmid_area) left=mid;
else right=midmid;
}
return cal(right);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf",&H,&h,&D);
double f=solve();
//double ss=cal(f);
printf("%.3lf\n",f);
}
}