Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6314 Accepted: 3370
Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes?
Here is a sample tiling of a 3x12 rectangle.
Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.
Output
For each test case, output one integer number giving the number of possible tilings.
Sample Input
2
8
12
-1
Sample Output
3
153
2131
Source
Waterloo local 2005.09.24
練點思維性的題。
n為奇數肯定為0,n為偶數,每次都是加兩列,我們把兩列看為一列,如果這一列與前面分開就只有三種方法即3*a[n-2],如果這一列不與前面的分開,那麼不可分解矩形都只有兩種情況所以為2*(a[n-4]+a[n-6]+……a[0])
化簡即為a[n]=4*a[n-2]-a[n-4]
[cpp]
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#define ll long long
using namespace std;
ll a[31];
int main()
{
ll n;
a[0]=1;a[2]=3;
for(int i=4;i<=30;i+=2)
a[i]=4*a[i-2]-a[i-4];
while(scanf("%lld",&n))
{
if(n==-1) break;
printf("%lld\n",a[n]);
}
}