Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 44186 Accepted: 15050
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2
Source
IOI 2000
有這麼個結論,需要加的字符的個數=原來字符串的長度-原來字符串和逆字符串的最長公共子序列的長度。
然後用滾動數組即可。
[cpp]
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
#include<string.h>
using namespace std;
char str[5010];
char s2[5010];
int dp[2][5010];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
scanf("%s",str);
for(int i=n-1;i>=0;i--)
s2[n-i-1]=str[i];
s2[n]='\0';
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
if(str[i-1]==s2[j-1])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
int l=dp[n%2][n];
cout<<n-l<<endl;
}
}