一、題目信息
Cow Multiplication
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10216 Accepted: 6993
Description
Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.
Input
* Line 1: Two space-separated integers: A and B.
Output
* Line 1: A single line that is the A*B in Bessie's style of multiplication.
Sample Input
123 45
Sample Output
54
二、參考代碼
為了避免使用%,/這些運算符,這裡我采用字符串。
[cpp]
#include <stdio.h>
int main(int argc,char * argv[])
{
int i,j,tmp_a,result=0;
char a[11],b[11];
scanf("%ld%ld",a,b);
for(i = 0;i < strlen(a);i++){
tmp_a = a[i] - '0';
for(j = 0;j < strlen(b);j++)
result += (a[i] - '0')*(b[j] - '0');
}
printf("%ld\n",result);
return 0;
}