Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15566 Accepted: 9275
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
Source
Tehran 2001
考察點:棧
讀懂題目就好做了
[cpp]
#include <iostream>
#include <cstring>
#include <stdio.h>
#include <math.h>
using namespace std;
int a[100],top,res[100],top2;
class str
{
public:
int pos;
char c;
}s1[100];
class statck
{
public:
int pos;
char c;
}s2[100];
int main()
{
int i,j,n,m,s,t,pos1,pos2;
cin>>t;
while(t--)
{
cin>>n;
for(i=0;i<=n-1;i++)
{
cin>>a[i];
}
top=0;
for(i=0;i<=n-1;i++)
{
if(!i)
{
for(j=1;j<=a[i];j++)
{
s1[top].c='(';
s1[top].pos=top;
top++;
}
s1[top].c=')';
s1[top].pos=top;
top++;
}else
{
for(j=1;j<=(a[i]-a[i-1]);j++)
{
s1[top].c='(';
s1[top].pos=top;
top++;
}
s1[top].c=')';
s1[top].pos=top;
top++;
}
}
n=top;
top=0;
top2=0;
memset(res,0,sizeof(res));
for(i=0;i<=n-1;i++)
{
if(s1[i].c=='(')
{
s2[top].c='(';
s2[top].pos=s1[i].pos;
top++;
}else
{
pos1=s2[top-1].pos;
top-=1;
pos2=s1[i].pos;
for(j=pos1;j<=pos2;j++)
{
if(s1[j].c==')')
{
res[top2]+=1;
}
}
top2++;
}
}
for(i=0;i<=n/2-1;i++)
{
if(!i)
{
cout<<res[i];
}else
{
cout<<" "<<res[i];
}
}
cout<<endl;
}
return 0;
}