Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8264 Accepted: 2247
Description
Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:
No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?
Input
The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.
Output
For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.
Sample Input
5
4 0
4 1
1 1
4 2
1 2
2 1
4 1
2 1
4 1
3 2
Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
Source
POJ Founder Monthly Contest – 2008.08.31, windy7926778
剛看到這題的時候就有點發懵,雖然我知道這是拓撲排序但都頭來還是沒做出來,不斷的變化思路,最終還是WA,無奈之下看了看解題報告,明白了思想,感覺特別簡單。
很容易懂
貼一下我的代碼:
#include <iostream>
#include <string>
using namespace std;
class num
{
public:
int end,next;
}a[1000000];
int b[210];
int status[210];
int res[210];
int in[210],out[210],n;
int main()
{
int deal();
int i,j,m,s,t,k;
int x,y;
cin>>t;
while(t--)
{
cin>>n>>m;
memset(b,-1,sizeof(b));
memset(in,0,sizeof(in));
memset(out,0,sizeof(out));
k=0;
for(i=1,j=0;i<=m;i++)
{
cin>>x>>y;
in[x]+=1; out[y]+=1;
a[j].end=x; a[j].next=b[y];
b[y]=j; j++;
if(x==y)
{
k=1;
}
}
if(k)
{
cout<<-1<<endl;
continue;
}
k=deal();
if(!k)
{
cout<<-1<<endl;
}else
{
for(i=1;i<=n;i++)
{
if(i==1)
{
cout<<res[i];
}else
{
cout<<" "<<res[i];
}
}
cout<<endl;
}
}
return 0;
}
int deal()
{
int i,j,k;
memset(status,0,sizeof(status));
for(i=n;i>=1;i--)
{
k=-1;
for(j=n;j>=1;j--)
{
if(!in[j]&&!status[j])
{
k=j;
break;
}
}
if(k==-1)
{
return 0;
}
res[k]=i; status[k]=1;
for(j=b[k];j!=-1;j=a[j].next)
{
in[a[j].end]-=1;
}
}
return 1;
}