A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.
A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.
A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y"are all their own reverses.
A list of all valid characters and their reverses is as follows.
Character Reverse Character Reverse Character Reverse
A A M M Y Y
B N Z 5
C O O 1 1
D P 2 S
E 3 Q 3 E
F R 4
G S 2 5 Z
H H T T 6
I I U U 7
J L V V 8 8
K W W 9
L J X X
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.
Input
Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.
Output
For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.
STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.
In addition, after each output line, you must print an empty line.
Sample Input
NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA
Sample Output
NOTAPALINDROME -- is not a palindrome.
ISAPALINILAPASI -- is a regular palindrome.
2A3MEAS -- is a mirrored string.
ATOYOTA -- is a mirrored palindrome.
【注意】:
題目意思:
判斷輸入的字符串是否是回文串還是鏡面字符串。
回文串:從左到右讀和從右到左讀是一樣的。
鏡面字符串:如果某個字符有鏡面字符,轉換為相應的鏡面字符。轉換後從左到右讀和從右到左讀是一樣的。
數字0和字母O是等價的。
【代碼】:
[cpp]
/*********************************
* 日期:2013-4-22
* 作者:SJF0115
* 題號: 題目401 - Palindromes
* 來源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=6&page=show_problem&problem=342
* 結果:AC
* 來源:UVA
* 總結:
**********************************/
#include<stdio.h>
#include<string.h>
char MirroredStr[] = {'A',' ',' ',' ','3',' ',' ','H',
'I','L',' ','J','M',' ','O',' ',' ',' ','2','T','U','V','W','X','Y','5'};
char MirroredNum[] = {'1','S','E',' ','Z',' ',' ','8',' '};
//判斷是否是回文
int IsPalindromes(char Str[]){
int i,j;
for(i = 0,j = strlen(Str)-1;i < j;i++,j--){
//0 和 O等價
if((Str[i] == '0' && Str[j] == 'O') || (Str[i] == 'O' && Str[j] == '0')){
continue;
}
if(Str[i] != Str[j]){
return 0;
}
}
return 1;
}
//判斷是否是鏡像字符串
int IsMirrored(char Str[]){
char temp[21];
int i,j,index;
int len = strlen(Str);
for(i = 0,j = len-1;i < len;i++,j--){
if(Str[i] >= 'A' && Str[i] <= 'Z'){
index = Str[i] - 'A';
temp[i] = MirroredStr[index];
}
else{
index = Str[i] - '1';
temp[i] = MirroredNum[index];
}
//0 和 O等價
if((temp[i] == '0' && Str[j] == 'O') || (temp[i] == 'O' && Str[j] == '0')){
continue;
}
if(temp[i] != Str[j]){
return 0;
}
}
return 1;
}
int main (){
char Str[21];
int i,len,IsP,IsM;
//freopen("C:\\Users\\XIAOSI\\Desktop\\acm.txt","r",stdin);
while(scanf("%s",Str) != EOF){
len = strlen(Str);
printf("%s -- ",Str);
//回文字符串
IsP = IsPalindromes(Str);
//鏡面字符串
IsM = IsMirrored(Str);
//輸出
if(IsP == 0 && IsM == 0){
printf("is not a palindrome.\n");
}
else if(IsP == 1 && IsM == 1){
printf("is a mirrored palindrome.\n");
}
else if(IsP == 1 && IsM == 0){
printf("is a regular palindrome.\n");
}
else if(IsP == 0 && IsM == 1){
printf("is a mirrored string.\n");
}
printf("\n");
}
return 0;
}
/*********************************
* 日期:2013-4-22
* 作者:SJF0115
* 題號: 題目401 - Palindromes
* 來源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=6&page=show_problem&problem=342
* 結果:AC
* 來源:UVA
* 總結:
**********************************/
#include<stdio.h>
#include<string.h>
char MirroredStr[] = {'A',' ',' ',' ','3',' ',' ','H',
'I','L',' ','J','M',' ','O',' ',' ',' ','2','T','U','V','W','X','Y','5'};
char MirroredNum[] = {'1','S','E',' ','Z',' ',' ','8',' '};
//判斷是否是回文
int IsPalindromes(char Str[]){
int i,j;
for(i = 0,j = strlen(Str)-1;i < j;i++,j--){
//0 和 O等價
if((Str[i] == '0' && Str[j] == 'O') || (Str[i] == 'O' && Str[j] == '0')){
continue;
}
if(Str[i] != Str[j]){
return 0;
}
}
return 1;
}
//判斷是否是鏡像字符串
int IsMirrored(char Str[]){
char temp[21];
int i,j,index;
int len = strlen(Str);
for(i = 0,j = len-1;i < len;i++,j--){
if(Str[i] >= 'A' && Str[i] <= 'Z'){
index = Str[i] - 'A';
temp[i] = MirroredStr[index];
}
else{
index = Str[i] - '1';
temp[i] = MirroredNum[index];
}
//0 和 O等價
if((temp[i] == '0' && Str[j] == 'O') || (temp[i] == 'O' && Str[j] == '0')){
continue;
}
if(temp[i] != Str[j]){
return 0;
}
}
return 1;
}
int main (){
char Str[21];
int i,len,IsP,IsM;
//freopen("C:\\Users\\XIAOSI\\Desktop\\acm.txt","r",stdin);
while(scanf("%s",Str) != EOF){
len = strlen(Str);
printf("%s -- ",Str);
//回文字符串
IsP = IsPalindromes(Str);
//鏡面字符串
IsM = IsMirrored(Str);
//輸出
if(IsP == 0 && IsM == 0){
printf("is not a palindrome.\n");
}
else if(IsP == 1 && IsM == 1){
printf("is a mirrored palindrome.\n");
}
else if(IsP == 1 && IsM == 0){
printf("is a regular palindrome.\n");
}
else if(IsP == 0 && IsM == 1){
printf("is a mirrored string.\n");
}
printf("\n");
}
return 0;
}