1) 題目
Tempter of the Bone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47967 Accepted Submission(s): 12905
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5S.X...X...XD....3 4 5S.X...X....D0 0 0
Sample Output
NOYES
2) 題意
在一個n行m列的迷宮中,每一步只能向上、下、左、右中任意方向走一格,迷宮中有圍牆的地方是無法到達的。從起點s開始,能否剛好走t步,到達e。
3) 數據范圍
迷宮大小最大為6*6,測試數據組數最大為50組。感覺上數據量很小,可實際上,如果在6*6的迷宮中,枚舉所有可能路徑的話,時間復雜度是指數級的,所以剪枝是關鍵。
4) 算法
先用BFS判斷s到e是否有路徑,以及這條最短路徑長度是否小於等於t,然後再進行回溯法+奇偶剪枝。
迷宮中回溯法的剪枝——奇偶剪枝
5) 代碼
[cpp]
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define MAXSIZE 10
int dir[4][2] = {-1, 0, 0, 1, 1, 0, 0, -1};
char maze[MAXSIZE][MAXSIZE];
bool vis[MAXSIZE][MAXSIZE];
int dx, dy;
bool finished;
void InitMaze(int m, int n)
{
int i;
for (i = 0; i < m+2; i++)
{
maze[i][0] = maze[i][n+1] = 'X';
}
for (i = 0; i < n+2; i++)
{
maze[0][i] = maze[m+1][i] = 'X';
}
}
void Backtrack(int x, int y, int rt)
{
vis[x][y] = true;
if (x == dx && y == dy)
{
if (rt == 0)
{
finished = true;
}
}
else
{
int i;
for (i = 0; i < 4; i++)
{
int nextx = x + dir[i][0];
int nexty = y + dir[i][1];
if (!vis[nextx][nexty] && maze[nextx][nexty] != 'X')
{
Backtrack(nextx, nexty, rt-1);
if (finished)
{
return;
}
}
}
}
vis[x][y] = false;
}
struct Position
{
int x, y;
int nsteps;
};
int BFS(int x, int y)
{
queue<Position> next;
Position currPos = {x, y, 0};
next.push(currPos);
vis[x][y] = true;
while (!next.empty())
{
currPos = next.front();
next.pop();
if (currPos.x == dx && currPos.y == dy)
{
return currPos.nsteps;
}
int i;
for (i = 0; i < 4; i++)
{
Position nextPos = currPos;
nextPos.x += dir[i][0];
nextPos.y += dir[i][1];
if (!vis[nextPos.x][nextPos.y] && maze[nextPos.x][nextPos.y] != 'X')
{
nextPos.nsteps++;
next.push(nextPos);
vis[nextPos.x][nextPos.y] = true;
}
}
}
return -1;
}
int Dist(int x, int y)
{
return abs(dx-x)+abs(dy-y);
}
int main(void)
{
int m, n, t;
while (scanf("%d%d%d", &m, &n, &t) != EOF)
{
getchar();
if (m == 0 && n == 0 && t == 0)
{
break;
}
InitMaze(m, n);
int sx, sy;
int i, j;
for (i = 1; i <= m; i++)
{
for (j = 1; j <= n; j++)
{
maze[i][j] = getchar();
if (maze[i][j] == 'S')
{
sx = i;
sy = j;
}
if (maze[i][j] == 'D')
{
dx = i;
dy = j;
}
}
getchar();
}
finished = false;
if (Dist(sx, sy) % 2 == t % 2) //奇偶剪枝
{
memset(vis, false, sizeof(vis));
int minNSteps = BFS(sx, sy);
if (minNSteps != -1 && minNSteps <= t)
{
memset(vis, false, sizeof(vis));
Backtrack(sx, sy, t);
}
}
if (finished)
{
puts("YES");
}
else
{
puts("NO");
}
}
return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define MAXSIZE 10
int dir[4][2] = {-1, 0, 0, 1, 1, 0, 0, -1};
char maze[MAXSIZE][MAXSIZE];
bool vis[MAXSIZE][MAXSIZE];
int dx, dy;
bool finished;
void InitMaze(int m, int n)
{
int i;
for (i = 0; i < m+2; i++)
{
maze[i][0] = maze[i][n+1] = 'X';
}
for (i = 0; i < n+2; i++)
{
maze[0][i] = maze[m+1][i] = 'X';
}
}
void Backtrack(int x, int y, int rt)
{
vis[x][y] = true;
if (x == dx && y == dy)
{
if (rt == 0)
{
finished = true;
}
}
else
{
int i;
for (i = 0; i < 4; i++)
{
int nextx = x + dir[i][0];
int nexty = y + dir[i][1];
if (!vis[nextx][nexty] && maze[nextx][nexty] != 'X')
{
Backtrack(nextx, nexty, rt-1);
if (finished)
{
return;
}
}
}
}
vis[x][y] = false;
}
struct Position
{
int x, y;
int nsteps;
};
int BFS(int x, int y)
{
queue<Position> next;
Position currPos = {x, y, 0};
next.push(currPos);
vis[x][y] = true;
while (!next.empty())
{
currPos = next.front();
next.pop();
if (currPos.x == dx && currPos.y == dy)
{
return currPos.nsteps;
}
int i;
for (i = 0; i < 4; i++)
{
Position nextPos = currPos;
nextPos.x += dir[i][0];
nextPos.y += dir[i][1];
if (!vis[nextPos.x][nextPos.y] && maze[nextPos.x][nextPos.y] != 'X')
{
nextPos.nsteps++;
next.push(nextPos);
vis[nextPos.x][nextPos.y] = true;
}
}
}
return -1;
}
int Dist(int x, int y)
{
return abs(dx-x)+abs(dy-y);
}
int main(void)
{
int m, n, t;
while (scanf("%d%d%d", &m, &n, &t) != EOF)
{
getchar();
if (m == 0 && n == 0 && t == 0)
{
break;
}
InitMaze(m, n);
int sx, sy;
int i, j;
for (i = 1; i <= m; i++)
{
for (j = 1; j <= n; j++)
{
maze[i][j] = getchar();
if (maze[i][j] == 'S')
{
sx = i;
sy = j;
}
if (maze[i][j] == 'D')
{
dx = i;
dy = j;
}
}
getchar();
}
finished = false;
if (Dist(sx, sy) % 2 == t % 2) //奇偶剪枝
{
memset(vis, false, sizeof(vis));
int minNSteps = BFS(sx, sy);
if (minNSteps != -1 && minNSteps <= t)
{
memset(vis, false, sizeof(vis));
Backtrack(sx, sy, t);
}
}
if (finished)
{
puts("YES");
}
else
{
puts("NO");
}
}
return 0;
}
6) 測試數據
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
5 5 9
...D.
X.XX.
.XX..
SX...
....X
7) 提交結果