Problem Description
C國的死對頭A國這段時間正在進行軍事演習,所以C國間諜頭子Derek和他手下Tidy又開始忙乎了。A國在海岸線沿直線布置了N個工兵營地,Derek和Tidy的任務就是要監視這些工兵營地的活動情況。由於采取了某種先進的監測手段,所以每個工兵營地的人數C國都掌握的一清二楚,每個工兵營地的人數都有可能發生變動,可能增加或減少若干人手,但這些都逃不過C國的監視。
中央情報局要研究敵人究竟演習什麼戰術,所以Tidy要隨時向Derek匯報某一段連續的工兵營地一共有多少人,例如Derek問:“Tidy,馬上匯報第3個營地到第10個營地共有多少人!”Tidy就要馬上開始計算這一段的總人數並匯報。但敵兵營地的人數經常變動,而Derek每次詢問的段都不一樣,所以Tidy不得不每次都一個一個營地的去數,很快就精疲力盡了,Derek對Tidy的計算速度越來越不滿:"你個死肥仔,算得這麼慢,我炒你鱿魚!”Tidy想:“你自己來算算看,這可真是一項累人的工作!我恨不得你炒我鱿魚呢!”無奈之下,Tidy只好打電話向計算機專家Windbreaker求救,Windbreaker說:“死肥仔,叫你平時做多點acm題和看多點算法書,現在嘗到苦果了吧!”Tidy說:"我知錯了。。。"但Windbreaker已經掛掉電話了。Tidy很苦惱,這麼算他真的會崩潰的,聰明的讀者,你能寫個程序幫他完成這項工作嗎?不過如果你的程序效率不夠高的話,Tidy還是會受到Derek的責罵的.
Input
第一行一個整數T,表示有T組數據。
每組數據第一行一個正整數N(N<=50000),表示敵人有N個工兵營地,接下來有N個正整數,第i個正整數ai代表第i個工兵營地裡開始時有ai個人(1<=ai<=50)。
接下來每行有一條命令,命令有4種形式:
(1) Add i j,i和j為正整數,表示第i個營地增加j個人(j不超過30)
(2)Sub i j ,i和j為正整數,表示第i個營地減少j個人(j不超過30);
(3)Query i j ,i和j為正整數,i<=j,表示詢問第i到第j個營地的總人數;
(4)End 表示結束,這條命令在每組數據最後出現;
每組數據最多有40000條命令
Output
對第i組數據,首先輸出“Case i:”和回車,
對於每個Query詢問,輸出一個整數並回車,表示詢問的段中的總人數,這個數保持在int以內。
Sample Input
1
10
1 2 3 4 5 6 7 8 9 10
Query 1 3
Add 3 6
Query 2 7
Sub 10 2
Add 6 3
Query 3 10
End
Sample Output
Case 1:
6
33
59
Author
Windbreaker
Recommend
Eddy
[cpp]
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
using namespace std;
const int N=50005;
struct Node
{
int l,r,sum;
}node[N*4];
int num[N];
void build(int root,int l,int r)
{
node[root].l=l;
node[root].r=r;
if(l==r)
{
node[root].sum=num[l];
return ;
}
int mid=(l+r)/2;
build(root<<1,l,mid);
build(root<<1|1,mid+1,r);
node[root].sum=node[root<<1].sum+node[root<<1|1].sum;
}
void update(int root,int pos,int u)//如果是葉子結點,則是pos對應的位置
{
if(node[root].l==node[root].r)
{
node[root].sum=u;
return ;
}
int mid=(node[root].l+node[root].r)/2;
if(pos<=mid)
update(root<<1,pos,u);
else
update(root<<1|1,pos,u);
node[root].sum=node[root<<1].sum+node[root<<1|1].sum;
}
int query(int root,int L,int R)
{
if(L<=node[root].l&&node[root].r<=R)
{
return node[root].sum;
}
int mid=(node[root].l+node[root].r)/2;
int ret=0;
if(L<=mid)
ret+=query(root<<1,L,R);
if(R>mid)
ret+=query(root<<1|1,L,R);
return ret;
}
int main()
{
int t,n;
scanf("%d",&t);
int cc=1;
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
build(1,1,n);
char s[10];
scanf("%s",s);
printf("Case %d:\n",cc++);
while(strcmp(s,"End")!=0)
{
int x,y;
scanf("%d%d",&x,&y);
if(s[0]=='Q')
{
if(x>y)
swap(x,y);
cout<<query(1,x,y)<<endl;
}
else if(s[0]=='A')
{
num[x]+=y;
update(1,x,num[x]);
}
else
{
num[x]-=y;
update(1,x,num[x]);
}
scanf("%s",s);
}
}
}
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
using namespace std;
const int N=50005;
struct Node
{
int l,r,sum;
}node[N*4];
int num[N];
void build(int root,int l,int r)
{
node[root].l=l;
node[root].r=r;
if(l==r)
{
node[root].sum=num[l];
return ;
}
int mid=(l+r)/2;
build(root<<1,l,mid);
build(root<<1|1,mid+1,r);
node[root].sum=node[root<<1].sum+node[root<<1|1].sum;
}
void update(int root,int pos,int u)//如果是葉子結點,則是pos對應的位置
{
if(node[root].l==node[root].r)
{
node[root].sum=u;
return ;
}
int mid=(node[root].l+node[root].r)/2;
if(pos<=mid)
update(root<<1,pos,u);
else
update(root<<1|1,pos,u);
node[root].sum=node[root<<1].sum+node[root<<1|1].sum;
}
int query(int root,int L,int R)
{
if(L<=node[root].l&&node[root].r<=R)
{
return node[root].sum;
}
int mid=(node[root].l+node[root].r)/2;
int ret=0;
if(L<=mid)
ret+=query(root<<1,L,R);
if(R>mid)
ret+=query(root<<1|1,L,R);
return ret;
}
int main()
{
int t,n;
scanf("%d",&t);
int cc=1;
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
build(1,1,n);
char s[10];
scanf("%s",s);
printf("Case %d:\n",cc++);
while(strcmp(s,"End")!=0)
{
int x,y;
scanf("%d%d",&x,&y);
if(s[0]=='Q')
{
if(x>y)
swap(x,y);
cout<<query(1,x,y)<<endl;
}
else if(s[0]=='A')
{
num[x]+=y;
update(1,x,num[x]);
}
else
{
num[x]-=y;
update(1,x,num[x]);
}
scanf("%s",s);
}
}
}