Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 18644 Accepted: 9907
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0Sample Output
45
59
6
13
[cpp]
#include <iostream>
#include<cstdio>
using namespace std;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int w,h,cnt;
char map[25][25];
bool path(int x,int y)
{ if(x<0||x>=h||y<0||y>=w)
return false;
return map[x][y]=='.'; }
void dfs(int x,int y) {
for(int i=0;i<4;i++)
{ int xx=x+dir[i][0];
int yy=y+dir[i][1];
if(path(xx,yy))
{ map[xx][yy]='#';
cnt++; dfs(xx,yy);
} } } int main() {
while(~scanf("%d%d",&w,&h),w+h)
{ for(int i=0;i<h;i++)
scanf("%s",map[i]);
cnt=1;
for(int i=0;i<h;i++)
for(int j=0;j<w;j++)
if(map[i][j]=='@')
{ dfs(i,j);
break; }
printf("%d\n",cnt); }
return 0; }