Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6341 Accepted: 1826
Description
Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:
Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.
Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.
Given the initial positions of the n chessmen, can you predict who will finally win the game?
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output
For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17
Sample Output
Bob will win
Georgia will win
Source
POJ Monthly--2004.07.18
先將數一一配對(a,b),若是奇數則把最左邊與0配對。
那麼若對方向左挪a,我們也挪動b相同步數。
那麼唯一會影響的就是各配對間的間隔。
假設有間隔c1,c2..cn
那麼相當於每次選一個數,減去至少1.
這就像nim取石,有n堆石子,每次至少取走其中一堆的至少一個,誰最先沒石子取就輸。
這個問題的答案是 c1^c2^..^cn=0時有必輸解,否則必勝。
都懂得……
證明:
假設你面對一個c1^c2^...^cn=0的局面
A:取走若干石子使c1^c2^...^cn=k
B:取走ci的最高位與k的最高位相同的那堆 ci^k個 //最高位的1^1=0,所以ci^k<ci
A:恭喜你還是必輸
[cpp]
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
int T,n,a[100000+10];
int main()
{
scanf("%d",&T);
while (T--)
{
scanf("%d",&n);
For(i,n) scanf("%d",&a[i]);
sort(a+1,a+1+n);
int tmp=0,head=1;
if (n%2) tmp=a[1]-1,head++;
for(int i=head;i<=n;i+=2)
{
tmp^=(a[i+1]-a[i]-1);
}
if (tmp) puts("Georgia will win");
else puts("Bob will win");
}
return 0;
}
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
int T,n,a[100000+10];
int main()
{
scanf("%d",&T);
while (T--)
{
scanf("%d",&n);
For(i,n) scanf("%d",&a[i]);
sort(a+1,a+1+n);
int tmp=0,head=1;
if (n%2) tmp=a[1]-1,head++;
for(int i=head;i<=n;i+=2)
{
tmp^=(a[i+1]-a[i]-1);
}
if (tmp) puts("Georgia will win");
else puts("Bob will win");
}
return 0;
}