數值統計
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67315 Accepted Submission(s): 33826
Problem Description
統計給定的n個數中,負數、零和正數的個數。
Input
輸入數據有多組,每組占一行,每行的第一個數是整數n(n<100),表示需要統計的數值的個數,然後是n個實數;如果n=0,則表示輸入結束,該行不做處理。
Output
對於每組輸入數據,輸出一行a,b和c,分別表示給定的數據中負數、零和正數的個數。
Sample Input
6 0 1 2 3 -1 0
5 1 2 3 4 0.5
0
Sample Output
1 2 3
0 0 5
Author
lcy
Source
C語言程序設計練習(二)
#include<stdio.h>
#include<math.h>
main()
{
int n,a,b,c;
double d;
while(scanf("%d",&n))
{
a=0; b=0; c=0;
while(n--)
{
scanf("%lf",&d);
if(d<0) a++;
else if(d==0)b++;
else if(d>0) c++;
}
printf("%d %d %d\n" ,a,b,c);
}
}