Common Subsequence---最長公共子序列,最長公共子序列
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
代碼如下:
#include<stdio.h>
#include<string.h>
#define N 2000
int max(int a, int b)
{
if(a>b)
return a;
else
return b;
}
char a[N], b[N];
int ch[N][N] = {0};
int main ()
{
int i, j, m, n;
while (scanf("%s%s", a, b)!=EOF)
{
memset(ch, 0 ,sizeof(ch)); //取零;
m = strlen(a);
n = strlen(b);
for (i = 1; i<=m; i++)
{
for(j = 1; j<=n; j++)
{
if(a[i-1] == b[j-1])
ch[i][j] = ch[i-1][j-1] + 1; //原因見下表;
else
ch[i][j] = max(ch[i-1][j], ch[i][j-1]);
}
}
printf("%d\n", ch[m][n]);
}
return 0;
}
例
a = abcfbc
b = abfcab
求最長公共子數列
a\b
a0 = a
a1 =b
a2 = c
a3 = f
a4 = b
a5 =c
a6
a7
a8
b0 = a
1
1
1
1
1
1
空格的值的求法見代碼
if(a[i-1] == b[j-1])
ch[i][j] = ch[i-1][j-1] + 1;
else
ch[i][j] = max(ch[i-1][j], ch[i][j-1]);
b1 = b
1
2
2
2
2
2
b2 = f
1
2
2
3
3
3
b3 = c
1
2
3
3
3
4
b4 = a
1
2
3
3
3
4
b5 = b
1
2
3
3
4
4
b6
b7
b8