[plain] Description
輸入一個字符串str和一個過濾字符串s(代表一個過濾表),將str中所有來自過濾表字符都濾除。
Input
輸入數據有2行,第一行為str,第二行為s,字符串均不超過70個字符。
Output
輸出濾除後的字符串。
Sample Input
asf$$a sf$$
$a
Sample Output
sf sf
Description
輸入一個字符串str和一個過濾字符串s(代表一個過濾表),將str中所有來自過濾表字符都濾除。
Input
輸入數據有2行,第一行為str,第二行為s,字符串均不超過70個字符。
Output
輸出濾除後的字符串。
Sample Input
asf$$a sf$$
$a
Sample Output
sf sf
[plain] #include <stdio.h>
#include <string.h>
int main()
{
int i;
int j;
int l;
int n;
int m;
char a[70];
char b[70];
char c[70];
gets(a);
gets(b);
n=strlen(a);
m=strlen(b);
for(i=0; i<m; i++)
{
l=0;
for(j=0; j<n; j++)
{
if(a[j]!=b[i])
{
c[l++]=a[j];
}
}
c[l]=0;
for(j=0; j<l; j++)
{
a[j]=c[j];
}
n=l;
a[j]=0;
}
for(i=0; c[i]; i++)
{
printf("%c", c[i]);
}
return 0;
}
#include <stdio.h>
#include <string.h>
int main()
{
int i;
int j;
int l;
int n;
int m;
char a[70];
char b[70];
char c[70];
gets(a);
gets(b);
n=strlen(a);
m=strlen(b);
for(i=0; i<m; i++)
{
l=0;
for(j=0; j<n; j++)
{
if(a[j]!=b[i])
{
c[l++]=a[j];
}
}
c[l]=0;
for(j=0; j<l; j++)
{
a[j]=c[j];
}
n=l;
a[j]=0;
}
for(i=0; c[i]; i++)
{
printf("%c", c[i]);
}
return 0;
}